jQuery 2.0 beta发布,不再支持IE6/7/8,jQuery 1.8

作者:人气:来源:2015-03-23

广告载入中...

jQuery开发团队今天发布了jQuery 1.9正式版本和jQuery 2.0 beta版本。 在jQuery 2.0中,将移除对老IE版本(IE 6/7/8)的支持,如果开发者比较在意老版本IE用户,只能使用jQuery 1.9及之前的版本了。 

jQuery 2.0

下面是2.0版的规划,该版本将于2013年初发布,就在jQuery 1.9发布之后不久。

移除对IE6/IE7/IE8的支持

jQuery 2.0所支持的APIs与jQuery 1.9一样。它并不会增加什么主要的特性,但却会移除对IE 6/7/8怪癖的支持,比如说臭名昭著的事件模型、IE7的“attroperties”、HTML5 shims等等。1.9与2.0的目标是对于他们所支持的API来说能够实现互换。jQuery 2.0将会更小、更快,同时不再有为了支持IE6/7/8所引入的那些问题。如果需要支持IE6/7/8,那么请选择1.9;否则,你既可以使用1.9也可以使用2.0。你还可以通过条件注释在使用IE6/7/8时只包含进1.9。


即便在jQuery 2.0发布后,jQuery团队也将会继续支持和维护1.9,只要IE6/7/8的影响还在就不会停止对其的支持。jQuery团队并未计划未来添加大量的新APIs,新的功能将会以兼容于1.9与2.0的插件的形式添加进来。

详细信息:jQuery Blog

jQuery 1.9


下面是1.9版的规划,该版本将于2013年初发布。

XSS防护

根据设计,$()方法可以创建HTML元素并运行脚本(如果传递进来的是

继续阅读:页面特效

分享吧:

手机移动